Convoy Trucking

Hyde Park => GTA & SA-MP => Topic started by: Matias on February 06, 2015, 01:02

Title: Bugged Sky :/
Post by: Matias on February 06, 2015, 01:02
Since i reinstalled GTA SA i keep getting this weird bug at the sky, it only happens at the morning with certain weather (10 & 11), it looks like something coming out the trailer
how can i solve it?  :(

(http://i.imgur.com/Jbq12dH.jpg)
Title: Re: Bugged Sky :/
Post by: Ethan on February 06, 2015, 01:13
graphics drivers up to date?
you have any timecyc mods that may be having problems?

I remember I had problems similar to this and I just need to update drivers to video card
Title: Re: Bugged Sky :/
Post by: Matias on February 06, 2015, 02:28
I don't have timecyc, only the sun mod, and it used to happen when i had clean game. I thought it could get fixed but it didn't.

And i have the last drivers for this videocard  :'(
Title: Re: Bugged Sky :/
Post by: nyolc8 on February 06, 2015, 13:39
it's at the same place on the sky or it's relative to the camera view? Can you show a video?
Title: Re: Bugged Sky :/
Post by: Nado on February 06, 2015, 15:12
i'm sure it has nothing related to graphics video or anything like that, I think it's timecyc, install another timecyc, and what's your Windows? because I had some graphics issues like texture flickering running gta sa in Windows 8 compatibility mode
Title: Re: Bugged Sky :/
Post by: Wizzer on February 06, 2015, 16:37
Is it possible that you installed a skybox before reinstalling your game?
Title: Re: Bugged Sky :/
Post by: Matias on February 06, 2015, 16:42
It also happened when having the clean game, and it only happens when facing tothe east, i will get a video asap
Title: Re: Bugged Sky :/
Post by: nyolc8 on February 06, 2015, 18:58
i'm sure it has nothing related to graphics video or anything like that, I think it's timecyc, install another timecyc, and what's your Windows? because I had some graphics issues like texture flickering running gta sa in Windows 8 compatibility mode
A timecyc only contains color(RGB,RGBA), drawdistance(farclip, and farclip fog) and some float datas (alphas, light multipliers)... how would that create a shape like this?

Also using an original gta_sa.exe + samp + edited timecyc = still original timecyc loaded in game. So I don't think it's the timecyc.

edit: maybe it's where the moon supposed to be... Syd, do you see the moon at night?
Title: Re: Bugged Sky :/
Post by: Matias on February 06, 2015, 19:18
Yes i have it, ps2 moon mod, but the bug was there even before getting that mod.

This is how it looks:

Title: Re: Bugged Sky :/
Post by: Wizzer on February 06, 2015, 21:01
it only happens when facing tothe east
Interesting..kinda looks like the bug shows everytime you see a sunlight, usually things like these happen if you install a skybox and only install the .cs file(s).

Have you tried to rename the Rockstar Games folder while reinstalling the game?

PS: It's not the worse bug you have, it used to happen with me too but it was flashing like hell at one camera point view lol
Title: Re: Bugged Sky :/
Post by: nyolc8 on February 06, 2015, 21:25
first of all... how do you have sun in samp without mods? What mod you use to enable the sun in samp? also you have ps2 atmoshphere mod too, right? maybe that makes that bug...
Title: Re: Bugged Sky :/
Post by: Matias on February 06, 2015, 22:00
first of all... how do you have sun in samp without mods? What mod you use to enable the sun in samp? also you have ps2 atmoshphere mod too, right? maybe that makes that bug...

I didn't say i had the sun without mods, the sun is there because of the cleo mod, but the bug was there even before installing the ps2 atmosphere and cleo sun mod, it was like that since the first time i installed it.
Title: Re: Bugged Sky :/
Post by: nyolc8 on February 06, 2015, 22:08
So if you remove the sun enabler cleo mod, the bug is still there? It's strange because as Wizzer said, it looks like it's related to the sun. The bug shows up when the sun show up on the screen.
Title: Re: Bugged Sky :/
Post by: Matias on February 06, 2015, 22:13
So if you remove the sun enabler cleo mod, the bug is still there? It's strange because as Wizzer said, it looks like it's related to the sun. The bug shows up when the sun show up on the screen.

It was there when i played single player without any mods and the sun was there, anyways i will try it and tell what happens.
Title: Re: Bugged Sky :/
Post by: Matias on February 06, 2015, 22:41
Ok. It looks like the bug at the sky is gone when removing the sun.cs mod from cleo folder.
Is there some any other sun mod which isn't that one?
Title: Re: Bugged Sky :/
Post by: nyolc8 on February 06, 2015, 23:10
If the bug visible in SP (sun appears without any mod), and also visible in SAMP (sun appears with sun.cs mod), then the bug not caused by the sun enabler mod, but by the sun itself.

So the question is... why is the stock sun bugged...  ::)
Title: Re: Bugged Sky :/
Post by: Matias on February 06, 2015, 23:18
Thats what i was trying to figure but i dont know which could be the reason :/
Title: Re: Bugged Sky :/
Post by: nyolc8 on February 06, 2015, 23:22
some tips: change the antialising option (if it's turned on then turn it off, if it's turned off then turn it on), change the resolution, change the mipmap option, change frame limiter option. Some of these may fix it (try the antialising first, that can fix some strange glitches).
Title: Re: Bugged Sky :/
Post by: Matias on February 07, 2015, 00:58
Oh ok, i will try it  :happycmas: